Teleportation changes(?) 1.15

Vivecraft general discussion, suggestions, chitchat.
Post Reply
PortaBob
Posts: 2
Joined: Mon Jun 29, 2020 6:56 pm

Teleportation changes(?) 1.15

Post by PortaBob »

I swear I've Google'd it and searched the boards here and on Discord and I don't see anyone posting that teleport seems different from 1.14 to 1.15. It seems very unlikely that I would be the only one out there who uses teleport loco so I must be defective in my searching. But I can't find any info and I'm very curious.

For me, teleportation seems to behave completely differently. For example, if I try to teleport through a doorway, unless I am perfectly centered outside the door and try to teleport to a perfectly centered position on the other side, I spring forward and then reappear at my starting point. As if when my shoulder clips a block it aborts. Jumps that do not give me any trouble in 1.14 just don't work in 1.15 for me.

Three questions:
1) Am I not crazy about this?
2) Was it intentional?
3) Is there any way (setting combo) to restore the teleport function like 1.14 while playing 1.15?

Thanks!

PortaBob

jrbudda
Site Admin
Posts: 572
Joined: Mon Jul 04, 2016 9:33 pm

Re: Teleportation changes(?) 1.15

Post by jrbudda »

Is this in singleplayer on both versions? teleport rubberbanding is a server-side anti-cheat thing so it may have changed internally between versions.

PortaBob
Posts: 2
Joined: Mon Jun 29, 2020 6:56 pm

Re: Teleportation changes(?) 1.15

Post by PortaBob »

I only play on single player, so not sure if it's also multi.

No other mods besides Vivecraft.

Bob

Post Reply