"Run in place" hotbar bug and swimming issue

Crashes, bugs or other issues
ScionNinja14
Posts: 2
Joined: Fri Aug 09, 2019 4:12 am

"Run in place" hotbar bug and swimming issue

Postby ScionNinja14 » Fri Aug 09, 2019 4:21 am

I am using the latest vivecraft, for 1.14.4

I don't know if this is a bug or some setting I've missed, but i started using the "run in place" movement and shaking my controllers to run forward.
But every time i shake the controllers, the hot bar automatically shifts to the farthest right slot. So if im running with a weapon it'l just move to the slot farthest to the right and then i have to keep going back to the slot i was using. If it helps, every time it happens, my right controller vibrates. I don't know if it registers me as hitting the ground but it shouldn't keep shifting my hot bar selection.

Also don't know if this is a bug or just a setting again but while using the "run in place", i cant climb or move when in contact with vines, and i cant actually swim. I just walk to the bottom of the ocean and then i can run on the floor. I can point upwards with both controllers and i float upwards but i cant swim.

jrbudda
Site Admin
Posts: 497
Joined: Mon Jul 04, 2016 9:33 pm

Re: "Run in place" hotbar bug and swimming issue

Postby jrbudda » Fri Aug 09, 2019 5:23 am

the hotbar thing is likely you touching it.
Climbing is getting an update right now, so hopefully that bug will go away.
I'm not sure about swimming, I will have to test it.

ScionNinja14
Posts: 2
Joined: Fri Aug 09, 2019 4:12 am

Re: "Run in place" hotbar bug and swimming issue

Postby ScionNinja14 » Sun Aug 11, 2019 1:17 am

jrbudda wrote:the hotbar thing is likely you touching it.
Climbing is getting an update right now, so hopefully that bug will go away.
I'm not sure about swimming, I will have to test it.


Yeah I figured out I was touching the right slot every time so I found and disabled the hotbar touch option. But I still don't know how to swim and why touching a vine gets me stuck

jrbudda
Site Admin
Posts: 497
Joined: Mon Jul 04, 2016 9:33 pm

Re: "Run in place" hotbar bug and swimming issue

Postby jrbudda » Sun Aug 11, 2019 6:17 am

We've got a bug fixed that causes some roomscale interactions to disable if your trigger is mechanically worn and doesnt go back to 0, theres a preview build of it in Discord, you might also fix it by turning off Analog Movement in the settings.