Torches not working

Crashes, bugs or other issues
burgl001
Posts: 4
Joined: Tue Sep 03, 2019 1:23 pm

Torches not working

Postby burgl001 » Tue Sep 03, 2019 1:34 pm

My torches in are not emitting any light. The only way they do emit light is when I am holding them. This only happens when I load into Vivecraft. They work fine with my non-vr game in the same single-player world. I have tried to erase the cache data through the optimize world options to no avail. I have the latest version of mincraft and vivecraft so shouldn't be a compatibility issue. I have also tried created new worlds but the problem persists.

jrbudda
Site Admin
Posts: 471
Joined: Mon Jul 04, 2016 9:33 pm

Re: Torches not working

Postby jrbudda » Tue Sep 03, 2019 5:16 pm

are you running shaders? it sounds like the lightmap is not updating correctly.

burgl001
Posts: 4
Joined: Tue Sep 03, 2019 1:23 pm

Re: Torches not working

Postby burgl001 » Wed Sep 04, 2019 2:42 pm

Yeah I'm running shaders. I will load my world with default shaders and see if that is the cause of the issue. If so, do you happen to know any work around. Otherwise I might just have to constantly equip a torch in my left hand while I mine with my right.

jrbudda
Site Admin
Posts: 471
Joined: Mon Jul 04, 2016 9:33 pm

Re: Torches not working

Postby jrbudda » Wed Sep 04, 2019 3:53 pm

your shaders might just be out of date

burgl001
Posts: 4
Joined: Tue Sep 03, 2019 1:23 pm

Re: Torches not working

Postby burgl001 » Wed Sep 04, 2019 8:34 pm

I'm not sure if that is the issue. I am using the latest iteration of SEUS PTGI E9. And they work fine with normal game; only problem is in vivecraft.

burgl001
Posts: 4
Joined: Tue Sep 03, 2019 1:23 pm

Re: Torches not working

Postby burgl001 » Thu Sep 05, 2019 9:46 pm

It seems you were right. They work fine with shaders turned off. Is there any solution? Or will I have to just use the torch in my left hand?

jrbudda
Site Admin
Posts: 471
Joined: Mon Jul 04, 2016 9:33 pm

Re: Torches not working

Postby jrbudda » Fri Sep 06, 2019 5:25 am

What version of optifine are you using when it works in non-vr?