Game crashes when running a server

Crashes, bugs or other issues
Post Reply
Splart2018
Posts: 6
Joined: Wed Mar 18, 2020 5:32 pm

Game crashes when running a server

Post by Splart2018 »

I was trying to play the game and host a server. usually this never has a issue unless it is a modpack with really heavy impact on performance but this doesnt seem to be the issue. when i launch the server it works perfectly fine for others both vr and 2d. i can join in 2d mode but once i switch to vr it crashes while loading the title screen. i have no idea how to fix it
crash_report.zip
inside this is the crash report text. idk why i couldnt just send the .txt
(1.68 KiB) Downloaded 4 times

jrbudda
Site Admin
Posts: 521
Joined: Mon Jul 04, 2016 9:33 pm

Re: Game crashes when running a server

Post by jrbudda »

I need the full latest.log file. Something is breaking setting up the SteamVR input / keybinds

Splart2018
Posts: 6
Joined: Wed Mar 18, 2020 5:32 pm

Re: Game crashes when running a server

Post by Splart2018 »

that is the only log it gives me idk how to get the "Full" log



---- Minecraft Crash Report ----
// Shall we play a game?

Time: 3/12/20 6:32 PM
Description: Unexpected error

java.lang.NullPointerException: Unexpected error
at org.vivecraft.provider.MCOpenVR.processBindings(MCOpenVR.java:1677)
at net.minecraft.client.Minecraft.func_71407_l(Minecraft.java:2454)
at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:1582)
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:647)
at net.minecraft.client.main.Main.main(Main.java:129)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at org.vivecraft.main.VivecraftMain.main(VivecraftMain.java:152)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
Minecraft Version: 1.12.2
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_51, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 3157525768 bytes (3011 MB) / 4244635648 bytes (4048 MB) up to 4244635648 bytes (4048 MB)
JVM Flags: 7 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx4G -Xms4G -XX:+UseParallelGC -XX:ParallelGCThreads=3 -XX:MaxGCPauseMillis=3 -Xmn256M
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP 9.42 Powered by Forge 14.23.5.2847 Optifine OptiFine_1.12.2_HD_U_E3 5 mods loaded, 5 mods active
States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored

| State | ID | Version | Source | Signature |
|:------ |:----------------- |:------------ |:----------------------------- |:--------- |
| LCHIJA | minecraft | 1.12.2 | minecraft.jar | None |
| LCHIJA | mcp | 9.42 | minecraft.jar | None |
| LCHIJA | FML | 8.0.99.99 | forge-1.12.2-14.23.5.2847.jar | None |
| LCHIJA | forge | 14.23.5.2847 | forge-1.12.2-14.23.5.2847.jar | None |
| LCHIJA | mercurius_updater | 1.0 | MercuriusUpdater-1.12.2.jar | None |

Loaded coremods (and transformers):
GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 441.20' Renderer: 'GeForce GTX 1060 6GB/PCIe/SSE2'
Launched Version: vivecraft-1.12.2-jrbudda-9-r7-forge
LWJGL: 2.9.4
OpenGL: GeForce GTX 1060 6GB/PCIe/SSE2 GL version 4.6.0 NVIDIA 441.20, NVIDIA Corporation
GL Caps: Using GL 1.3 multitexturing.
Using GL 1.3 texture combiners.
Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
Shaders are available because OpenGL 2.1 is supported.
VBOs are available because OpenGL 1.5 is supported.

Using VBOs: Yes
Is Modded: Definitely; Client brand changed to 'fml,forge'
Type: Client (map_client.txt)
Resource Packs: vanilla, programer_art, file/Nate's+Tweaks+0.32.zip
Current Language: English (US)
Profiler Position: N/A (disabled)
CPU: 12x AMD Ryzen 5 2600 Six-Core Processor

jrbudda
Site Admin
Posts: 521
Joined: Mon Jul 04, 2016 9:33 pm

Re: Game crashes when running a server

Post by jrbudda »

getting logs is covered in the FAQ

jrbudda
Site Admin
Posts: 521
Joined: Mon Jul 04, 2016 9:33 pm

Re: Game crashes when running a server

Post by jrbudda »

This is pure speculation, but are you using a mobile VR type system with some kind of intermediate software? If that's the case the issue is likely your software does not support steamvr input.

Splart2018
Posts: 6
Joined: Wed Mar 18, 2020 5:32 pm

Re: Game crashes when running a server

Post by Splart2018 »

it doesnt actually make a log file from what i see
Capture.PNG
Capture.PNG (195.38 KiB) Viewed 179 times

Splart2018
Posts: 6
Joined: Wed Mar 18, 2020 5:32 pm

Re: Game crashes when running a server

Post by Splart2018 »

im using an oculus rift s and running the game normally works perfectly fine its only when the server is up is when issues occur

jrbudda
Site Admin
Posts: 521
Joined: Mon Jul 04, 2016 9:33 pm

Re: Game crashes when running a server

Post by jrbudda »

The oculus software is a RAM hog and tends to explode when it runs out. You could try allocating less memory to vivecraft. You might be able to get away with a 1gb allocation instead of 2.

Splart2018
Posts: 6
Joined: Wed Mar 18, 2020 5:32 pm

Re: Game crashes when running a server

Post by Splart2018 »

oh...... i gave it 6 g cause sometimes it would give me an error of not having enough ram
i have 16g total ill try giving it like 2 or 3

Splart2018
Posts: 6
Joined: Wed Mar 18, 2020 5:32 pm

Re: Game crashes when running a server

Post by Splart2018 »

i cant believe something like lowering the ram would fix it but it worked
thanks

Post Reply